注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

php开发lamp

《西安--木木》-经历丰富了生活。 架构师QQ群: 246695517

 
 
 

日志

 
 

PHP 的未来:了解 PHP6 的变化及其对脚本的影响  

2014-08-26 14:49:12|  分类: php基础 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |


PHP 的未来:了解 PHP6 的变化及其对脚本的影响 -  灵听溪水  - php开发lamp-王伟
 

了解 PHP6 的变化及其对脚本的影响

PHP 的版本 V6 包含一些新特性和语法改进,从面向对象的角度看,PHP6 更加易于使用。其他重要特性(比如在许多核心函数中支持 Unicode)反映了 PHP V6 力争获得更好的国际通用性支持和健壮性。

PHP 已经很流行,它不仅用于各个领域(根据 Netcraft),而且还得到大部分 ISP 的支持和知名 Web 公司(比如 Yahoo!)的使用。此外,未来的 PHP 版本将引入新的特性以提高其易用性和安全性。您已经为使用 PHP V6 做好准备了吗?假设您要升级到 PHP V6,您的脚本能正常执行吗?或者需要进行一些更改?本文主要介绍 PHP V6 的变化(一些特性向后支持 PHP V5.x 版本),您可能需要根据这些变化对当前的脚本作出一些调整。

如果您尚未使用 PHP,并且一直考虑使用它,那么可以看看它的最新特性。这些特性 —— 从 Unicode 支持到 XML 支持 —— 将让您能够更加轻松地编写出特性丰富的 PHP 应用程序。

PHP V6 的新特性

PHP V6 的初步副本已经发布,所以您可以下载它并试用本文列出的许多特性和更改。
改进的 Unicode 支持
PHP V6 的最大改进是在许多核心函数中支持 Unicode 字符串。这个新特性有巨大的影响,因为它允许 PHP 支持更广泛的字符集,从而获得更多的国际支持。所以,如果您是一位使用不同语言(比如 Java? 编程语言,这些语言的国际化(il8n)支持比 PHP 好)的开发人员或架构师,那么您应该看看国际化支持改进后的 PHP。

现在,已经可以下载和使用针对开发人员的 PHP V6,所以您可以看到其中的一些特性已经支持 Unicode 字符串。

什么是 Unicode?

Unicode 是一组字符、字符编码和编码方法行业标准,其主要目标是支持 i18n 和本地化 (i10n)。Unicode Transformation Format (UTF) 为 Unicode 指定一种编码字符的方式。

名称空间
名称空间 是一种避免函数名和类名出现冲突的方法,并且不会在命名约定中使用前缀,从而增强了函数名和类名的可读性。因此通过使用名称空间,您可以使用可能已被他人使用的类名,但不用担心出现问题。清单 1 提供一个 PHP 的名称空间例子。

您不需要对代码进行任何更新或修改,因为不包含名称空间的 PHP 代码将能够正常运行。因为名称空间特性向后支持至 PHP V5.3,因此当该特性可用时,您可以在 PHP 应用程序中引入名称空间。

清单 1. 名称空间的例子

<?php
// I'm not sure why I would implement my own XMLWriter, but at least
// the name of this one won't collide with the one built in to PHP
namespace NathanAGood;
class XMLWriter
{
    // Implementation here...
}
$writer = new NathanAGood::XMLWriter();
?>

Web 2.0 特性

取决于您使用 PHP 的方式以及当前的代码,PHP V6 中的语言和语法差别对您的影响可能没有接下来的特性大,这些特性允许您将 Web 2.0 特性直接引入到 PHP 应用程序中。

SOAP

SOAP 是 Web 服务采用的协议之一,并且在许多其他语言中都得到支持,比如 Java 编程语言和 Microsoft? .NET。尽管有许多其他方式可以使用和公开 Web 服务(比如 Representational State Transfer,REST),SOAP 仍然是实现不同平台之间的交互性的常用方法。除了 PHP Extension and Application Repository (PEAR) 库中的 SOAP 模块之外,PHP V5 还引入了一个 SOAP 扩展。默认情况下这个扩展是禁用的,所以您或您的 ISP 必须启用它。此外,您可以通过 PEAR 包构建 SOAP 客户端和服务器,比如 SOAP 包。

除非您更改了默认设置,否则 SOAP 扩展在 PHP V6 中是启用的。这些扩展为实现 SOAP 客户端和 SOAP 服务器提供一种简易的方法,从而使您能够构建使用和提供 Web 服务的 PHP 应用程序。

如果默认启用了 SOAP 扩展,您就不需要在 PHP 中配置它们。如果您开发了 PHP 应用程序并发布给 ISP,那么您必须和 ISP 进行核实,确保他们在升级时为您启用 SOAP 扩展。

XML

从 PHP V5.1 开始,XMLReader 和 XMLWriter 就成为了 PHP 核心的一部分,这使您能够在 PHP 应用程序中更加轻松地处理 XML。与 SOAP 扩展一样,如果您使用 SOAP 或 XML 的话,这个特性是个好消息,因为 PHP V6 比 V4 更适合您。

XMLWriter 和 XMLReader 是基于流的面向对象类,它们允许您读写 XML,并且不要担心 XML 的细节。

删除的特性

PHP V6 在添加一些新特性的同时,也删除了以前版本中的一些函数和特性。被删除的大部分东西,比如 register_globalssafe_mode, 在当前的 PHP 中都被广泛认为是 “有漏洞的”,因为它们可能招致安全风险。为了保持 PHP 的简洁性,将删除下面小节列出的函数和特性。在 ISP 或企业升级到 PHP V6 之后,反对删除这些内容的人很可能会给现有的脚本带来安全问题,而支持删除的人将会很幸运,因为 PHP 团队为他们修复了一些漏洞,并且提供更加干净、安全的实现。

从 PHP V6 删除的特性包括:

  • magic_quotes
  • register_globals
  • register_long_arrays
  • safe_mode

magic_quotes

由于 magic_quotes 导致可移植性、性能和易用性方面的问题,所以 PHP 文档不鼓励使用它。鉴于这个原因,PHP V6 干脆删除了该特性。因此,在升级到 PHP V6 之前,要确保您的代码没有使用 magic_quotes。 如果您正在使用 magic_quotes 为数据库调用转换字符串类型,请使用数据库实现的参数化查询(如果支持的话)。如果不支持参数化查询,请使用数据库实现的类型转换函数,比如针对 MySQL 的 mysql_escape_string 或针对 PostgreSQL 的 pg_escape_string。 清单 2 显示了一个使用 magic_quotes 的例子。
清单 2. 使用 magic_quotes(不推荐)

<?php
// Assuming magic_quotes is on...
$sql = "INSERT INTO USERS (USERNAME) VALUES $_GET['username']";
?>

在针对新版本 PHP 进行处理之后,您的 PHP 代码应该类似于清单 3。

清单 3. 使用参数化查询(推荐)

<?php
// Using the proper parameterized query method for MySQL, as an example
$statement = $dbh->prepare("INSERT INTO USERS (USERNAME) VALUES ?");
$statement->execute(array($_GET['username']));
?>

既然即将完全删除对 magic_quotes 的支持,get_magic_quotes_gpc() 函数就不再可用。这可能会影响一些老版本的 PHP 脚本,因此在更新之前,确保对所有存在这些函数的地方进行修复。

register_globals

register_globals 配置键在 PHP V4.2 中已经默认关闭,当时也引起了争议。当 register_globals 打开之后,就能轻松地使用可能注入了来自 HTML 表单的值的变量。因为在脚本中并不真正需要初始化这些变量,所以很容易编写出带有安全漏洞的脚本。清单 4 是一个使用 register_globals 的例子。

清单 4. 使用 register_globals(不推荐)

<?php
// A security hole, because if register_globals is on, the value for user_authorized
// can be set by a user sending them on the query string
// (i.e., http://www.example.com/myscript.php?user_authorized=true)
if ($user_authorized) {
    // Show them everyone's sensitive data...
}
?>

如果您的 PHP 代码使用了全局变量,那么应该更新它。即便不是为了使用新版本的 PHP 而更新它,从安全角度考虑,您也应该进行更新。更新完成之后,您的代码应该类似于清单 5。
清单 5. 更加明确的代码(推荐)

<?php
function is_authorized() {
    if (isset($_SESSION['user'])) {
        return true;
    } else {
        return false;
    }
}
$user_authorized = is_authorized();
?>

register_long_arrays

当打开 register_long_arrays 设置时,它将注册 $HTTP_*_VARS 预定义变量。如果您目前使用更长的变量,那么需要进行更新,以适应更短的变量。这个设置是在 PHP V5 中引入的(考虑到向后兼容性),但出于性能考虑,PHP 团队建议关闭它。清单 6 是一个使用 register_long-arrays 的例子。
清单 6. 使用注册数组(不推荐)

<?php
    // Echo's the name of the user value given on the query string, like
    // http://www.example.com/myscript.php?username=ngood
    echo "Welcome, $HTTP_GET_VARS['username']!";
?>

如果您的 PHP 代码类似于清单 6,那么更新它,如清单 7 所示。如果 register_long_arrays 设置是打开的,那么关闭它,然后再次测试脚本。
清单 7. 使用 $_GET(推荐)

<?php
    // Using the supported $_GET array instead.
    echo "Welcome, $_GET['username']!";
?>

safe_mode

当打开了 safe_mode 配置键时,它确保所操作的文件的所有者与所执行的脚本的所有者匹配。这最初作为在共享服务器环境中进行操作时(许多 ISP 都这样做)处理安全性的一种方法。(要获得受 safe_mode 更改影响的函数列表的链接,请参见 参 考资料)。您的 PHP 代码不会受这一更改的影响,但是有必要了解它,免得在未来设置 PHP 时使用它或在脚本中依赖它。

PHP 标记

Microsoft Active Server Pages (ASP) 样式的标记(PHP 标记的缩短版)不再受支持。要确保您的脚步不存在这种问题,请检查是否在 PHP 文件中使用了 <%%> 标记。如果使用了,那么分别将其替换为 <?php?>

FreeType 1 和 GD 1

PHP 团队删除了对 FreeType 1 和 GD 1 的支持,其理由是这两个库缺乏持续开发,并且已经不适应时代要求。不过,这两个库的更新版本将提供更好的功能。要更多地了解 FreeType 和 GD,参见 参 考资料。

ereg

将从核心 PHP 支持中删除支持 Portable Operating System Interface (POSIX) 正则表达式的 ereg 扩展。如果您正在使用 POSIX 正则表达式函数之一,这一更改将带来影响,除非您包含 ereg 功能。如果您正在使用 POSIX 正则表达式,可以考虑更新正则表达式函数,以使用 Perl-Compatible Regular Expression (PCRE) 函数,因为它们提供更多的特性和更好的平台。表 1 列出了删除 ereg 之后将不可用的 POSIX 正则表达式函数。同时展示了它们的 PCRE 代替函数。
表 1. ereg() 函数及其 PCRE 等效函数

ereg() 函数 类似的 preg() 函数
ereg(), eregi() preg_match()
ereg_replace(), ereg_replacei() preg_replace()

safe_mode

当打开了 safe_mode 配置键时,它确保所操作的文件的所有者与所执行的脚本的所有者匹配。这最初作为在共享服务器环境中进行操作时(许多 ISP 都这样做)处理安全性的一种方法。(要获得受 safe_mode 更改影响的函数列表的链接,请参见 参 考资料)。您的 PHP 代码不会受这一更改的影响,但是有必要了解它,免得在未来设置 PHP 时使用它或在脚本中依赖它。

PHP 标记

Microsoft Active Server Pages (ASP) 样式的标记(PHP 标记的缩短版)不再受支持。要确保您的脚步不存在这种问题,请检查是否在 PHP 文件中使用了 <%%> 标记。如果使用了,那么分别将其替换为 <?php?>

FreeType 1 和 GD 1

PHP 团队删除了对 FreeType 1 和 GD 1 的支持,其理由是这两个库缺乏持续开发,并且已经不适应时代要求。不过,这两个库的更新版本将提供更好的功能。要更多地了解 FreeType 和 GD,参见 参 考资料。

ereg

将从核心 PHP 支持中删除支持 Portable Operating System Interface (POSIX) 正则表达式的 ereg 扩展。如果您正在使用 POSIX 正则表达式函数之一,这一更改将带来影响,除非您包含 ereg 功能。如果您正在使用 POSIX 正则表达式,可以考虑更新正则表达式函数,以使用 Perl-Compatible Regular Expression (PCRE) 函数,因为它们提供更多的特性和更好的平台。表 1 列出了删除 ereg 之后将不可用的 POSIX 正则表达式函数。同时展示了它们的 PCRE 代替函数。
表 1. ereg() 函数及其 PCRE 等效函数

ereg() 函数 类似的 preg() 函数
ereg(), eregi() preg_match()
ereg_replace(), ereg_replacei() preg_replace()

PHP V5.3
这里提到的一些特性还将迁移到 PHP V5.3,5.3 版本是在 2008 年的第一季度发布的。您可能希望升级到 V5.3 并开始使用这些特性,但是直接迁移到 PHP V6 能够节省该步骤。下面列出向后支持 v5.3 的特性:

  • 名称空间
  • 默认情况下在核心函数中包含 XMLReader 和 XMLWriter
PHP 的未来:了解 PHP6 的变化及其对脚本的影响 -  灵听溪水  - php开发lamp-王伟
  评论这张
 
阅读(282)| 评论(2)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017