注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

php开发lamp

《西安--木木》-经历丰富了生活。 架构师QQ群: 246695517

 
 
 

日志

 
 

Ubuntu 下 编译安装PHP5.3.8  

2013-05-01 17:53:19|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 
先下载PHP5的源码包,解压出来,打开终端,cd 进入php解压目录
> ./configure --prefix=/usr/local/php --with-mysql=/usr/local/mysql --with-apxs2=/usr/local/apache2/bin/apxs --with-config-file-path=/usr/local/php --enable-track-vars
说明:
--prefix=[DIR] 指定安装目录
--with-mysql=[DIR] 指定mysql数据服务器安装的位置,安装后PHP将支持MySQL
--with-apxs2=[DIR] 编译共享的 Apache 2.0 模块。DIR 是可选的 Apache apxs 工具的路径,默认指向 apxs
--with-config-file-path=[DIR] 指定了PHP配置文件所在的目录
--enable-track-vars 为启动cookie的get/post等追踪功能
直接这样执行后,将会看到这样一个错误:
configure: error: xml2-config not found. Please check your libxml2 installation.
这是由于系统缺少PHP所需的库文件导致的,根据提示,进行如下操作:
sudo apt-get install libxml2(按Tab键)
将会看到如下信息:
libxml2 libxml2-dev libxml2-headers libxml2-utils
这里需要安装的是libxml2-dev软件包(该软件为Ubuntu-Server自带的,需要使用Ubuntu-Server光盘安装),操作如下:
sudo apt-get install libxml2-dev
库文件安装完成后,重新开始编译:
编译完成后将会看到“Thank you for using PHP.”的字样,表明PHP已经配置成功了。

>make
> make install

--------------------------------------

非root用户

-----------------------------------
>sudo make
>sudo make install

  评论这张
 
阅读(466)| 评论(2)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017